Quantcast
Jump to content

ChrisG

Time to join in on the fun!!

Recommended Posts

I've always been kind of a pirate when it come to the internet by taking the info I need and then leaving nothing behind. I figured it was about time to start contributing to the comunity and participate. I must admit I have been reading a while and would like to thank everyone for the postive influence and help making an informed decision with my T2. It's nice to know that there are people out there what will respond to problems without biased opintions. As I'm sure you are all aware this is pretty much the only resource other than your local dealer and the Joyner USA website. I really appretiate the fact that you guys have started organizing things to make this an even better place for info.

So thanks again and I look forward to your insight in my posts!

Chris

Share this post


Link to post
Share on other sites




Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Forum Topics

    • Massimo no start

      2017 msu500 efi. Has spark and fuel. Valves are within clearances.  Leave key on I get a 118 code. Ect sensor? Could this keep it from starting Old plug was black

      By Swampdonkey, in Hisun UTV SxS Forum

      • 9 replies
      • 858 views
    • hisun 800 intake backfire/no start

      I am working on a friends hisun 800. he said whenever you transport it on a trailer it takes forever to start and he has to floor it to get it to start. he also said it wouldn't go over 30mph like it was being held back. I get it to my house try to start it and all im getting is backfire through intake. I checked spark it was good. I know its a no no but I sprayed a small shot of starting fluid in airbox to see if it would start and it backfired and lit the fluid on fire. currently I am wondering if the valves may be out of adjustment anybody have any suggestions or help would be greatly appreciated.

      By huey224, in Hisun UTV SxS Forum

      • 2 replies
      • 157 views
    • Doesn't want to start

      My 2013 500 will only start if I floor the gas pedal and then once it starts I have to pump the gas until it warms up a little it sounds horrible until it warms up.(around 20 seconds)and then it will stay running. The exhaust smells like raw gas for a little while. The throttle body has been changed. Someone suggested the mass air flow sensor could be the problem ( is that the MAP). It has been to 2 different shops with it not being fixed. I haven't been able to ride it since last fall.

      Does anyone have any suggestions?

      By Rwpjtk, in Hisun UTV SxS Forum

      • 17 replies
      • 1,893 views
    • Cub Cadet Diesel UTV key on no lights and wont start

      New here!  I have a 2003 Cub Cadet Volunteer Diesel ran everyday 1 day fine nothing the next. anyone had this problem? when I turn on the key not even the lights will come on. I took the switch apart it seems fine put it back in. checked the 2 blowout fuses are also fine (even tried new ones), switched the 3 relays around they seem fine to hate to have to take it in an get wallet raped someone must have had this problem before any help would be greatly appreciated!

      By uponahill, in Cub Cadet UTV SxS Forum

      • 50 replies
      • 2,510 views
    • Initial Start Up Procedure

      Im about 3-4 more weeks on my engine. (Im counting one week to re install into frame since thats how long it took me to take it out) What should i do when i first start it up? I know not go over 3/4 throttle. Any other tips or tricks? Kawasaki single cylinder 286 cc. The usable compression range is like 114 psi to 168 psi, i believe. What should i shoot for?       @kenfain

      By Travis, in UTV General Discussion

      • 4 replies
      • 308 views


×