Quantcast
Jump to content

Location of massimo tboss 410 ecu


OLDVAIL

Recommended Posts

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Topics

    • By htrotte
      #1   While troubleshooting an issue with temp warning light I discovered another temp switch mounted in the pipe going to the head  The two switches are literally 6 inches apart.  Does anyone know what this third switch is used for?  If i can figure out how I will post pictures.
      Author #2   Finally got the pictures took.  See the photo and tell me if you know what the switch on the right is.
      It looks to be factory and I know the girl who bought it new and she didn't install it.
      I can't find anything on it in any manual i have looked at.  Any help would be appreciated.

    • By joel b
      i purchased a brand new massimo tboss 410 and from day 1 it wont operate in reverse.  When i pop in reverse and give it gas it will die out.  when i pop in reverse sometimes in will die right away (before giving any gas) and 1 time out of 100 when i pop in reverse it will operate perfectly fine.   and yes, it operates perfectly dine in normal drive H and L.  any thoughts??   when i called the dealer i got it from they had no idea.  
    • By KMart
      I have a Massimo 400 Buck that overheats and the antifreeze blows out of the motor everywhere! I don’t have to be doing anything but just driving through the field.  It only has 26 miles on it.  I don’t think the fan is turning to cool the motor.  Any ideas how to fix this?
    • By Michael Wood
      I have a 2018 Massimo Buck 400 with 278 miles. 
      Having issues with my brakes. Took the buggy hunting and when I let my foot off the gas pedal it pulls without pressing on the brake. I looked and the pads on all 4 wheels are all toast. The E-Brake hasn’t been on since I have had it. I am guessing it may be a master cylinder issue because all 4 pads are gone. They all seem to have worn evenly that’s why I think the master cylinder. Just got the machine used from a older couple and they said it sat for some time in there pole barn. Possibly the brake lines? Calipers? I took one brake apart and when I depressed the caliper it didn’t stay. Any help is muck appreciated. 
    • By doncaron
      Hello 
      I have a 2022 Massimo t-boss 550. I’m looking for a fix for my timing problem. It keeps getting out of timing. Now I’m trying to find the proper parts for the linhai motor. I’m looking for tensioner chain and gear. If there’s anything else I can do to fix this issue please let me know. Unfortunately I can’t afford to get something better so I got to get it fixed. Thanks in advance. 
      Don
×
×
  • Create New...