Quantcast
Jump to content

TRACKER Off Road UTV SxS Forum

This is for all of you TRACKER Off Road UTV, SxS (Side by Side) owners. Discussions about TRACKER Off Road specific topics including the OS400, 500s, 800SX, EX iS, SXV1000 and XTR1000 models.


36 topics in this forum

    • 2 replies
    • 63 views
    • 6 replies
    • 344 views
    • 4 replies
    • 204 views
  1. Tracker 800sx water in fuel

    • 2 replies
    • 410 views
  2. Radiator flush

    • 7 replies
    • 274 views
    • 14 replies
    • 2.1k views
    • 2 replies
    • 465 views
    • 0 replies
    • 427 views
    • 1 reply
    • 415 views
    • 3 replies
    • 1.6k views
    • 7 replies
    • 725 views
  3. Mirrors for 800sx

    • 10 replies
    • 1.5k views
    • 2 replies
    • 985 views
    • 2 replies
    • 889 views
  4. Tracker 800SX LE cover

    • 1 reply
    • 637 views
    • 2 replies
    • 791 views
    • 0 replies
    • 639 views
  5. Tracker

    • 2 replies
    • 298 views
    • 8 replies
    • 1.8k views
    • 2 replies
    • 546 views
  6. Added Inferno Heater.

    • 1 reply
    • 487 views
    • 1 reply
    • 802 views
    • 7 replies
    • 10.1k views
  7. New to the group

    • 2 replies
    • 402 views
    • 0 replies
    • 456 views
  • Latest Posts

    • kawasaki mule with cab, rig up a heater, add plow and you are set......  
    • Welcome!! First off, What's your budget? I would recommend a Kawasaki Mule SX model, it will do all of what you're wanting for around $7,000 + accessories. but since you seem to be reliant upon the machine to clear snow, the SX has some problems in the colder climates with it's EPA Evaporative system freezing due to moisture collecting  and just causing a general pain in the rear with it.    
    • Same problem on my 2015 Sector 550. Full charge in battery.  No dash lights, no horn, no start, no nothing. I thoroughly cleaned every connection at the battery. The bat compartment looked new when I was done. SAME problem. NO change. So I used a known GOOD fuse/relay unit. Same problem. NO change. I even attempted a jump start from a running vehicle. Same problem. No change. So I took it to a real Hisun mechanic who replaced the battery and it started right up. (I couldve sworn I did a LOAD test on my battery. I must've been wrong. I NOW keep the UTV S/S on a trickle starter each time I park it. This unit only had 300 miles on it when I bought it from a friend who didn't use it much. I'm learning as I go. Good luck.
    • Yep. Mine is the same. This shows you have a full tank. The indicators will disappear from right to left as it consumes fuel.
    • Condolences brother.. Massimo is the worst manufacturer on earth.. Absolute rip off company.. They wont fix any defect .. Mine broke on ITS VERY FIRST DAY with only ONE MILE on odometer .. They refused to pay repair shop.. and it was recommended on phone by  Company Rep in Dallas.   I tried to trade mine with less than 100 miles on it, on a new Honda Pioneer.... They refused to even consider Massimo.  Everyone should get together and SUE them 

×
×
  • Create New...