Quantcast
Jump to content

UTV Events and Rallies

UTV Events and Rallies - Post any UTV events that you are aware of and share with the community.

82 topics in this forum

    • 5 replies
    • 5,263 views
    • 4 replies
    • 4,786 views
    • 10 replies
    • 3,759 views
    • 1 reply
    • 3,685 views
  1. OR Ouray, CO.

    • 5 replies
    • 3,552 views
    • 1 reply
    • 3,538 views
    • 15 replies
    • 3,236 views
    • 0 replies
    • 2,980 views
    • 1 reply
    • 2,931 views
    • 0 replies
    • 2,887 views
    • 6 replies
    • 2,807 views
    • 3 replies
    • 2,575 views
  2. Eastern North Carolina sXs series racing

    • 0 replies
    • 2,477 views
    • 1 reply
    • 2,459 views
    • 8 replies
    • 2,342 views
  3. 3rd anual MOAB UTV Rally

    • 2 replies
    • 2,330 views
    • 0 replies
    • 2,232 views
    • 15 replies
    • 2,096 views
    • 0 replies
    • 2,021 views
    • 1 reply
    • 2,005 views
  4. SxS Adventure Rally

    • 4 replies
    • 1,910 views
    • 3 replies
    • 1,888 views
    • 0 replies
    • 1,845 views
  5. Rumble on the ridge 2010

    • 0 replies
    • 1,816 views
    • 2 replies
    • 1,706 views
  • Latest Posts

    • Anyone know where i can get headers bought or made for my 800cc F8b?  I’ve seen some older posts where guys were making/selling them. Or does anyone have some you’d like to sell me? thx
    • I just finished rebuilding my 800cc SOHC f8b and boy did I wake this little engine up with port, polish , exhaust, cam and valves! I’ve richened up my stock carb about as far as it will go and still seems to be running on the lean side especially under hard acceleration. I’ve read some posts and going to try my hands at a weber 32/36 two questions: 1- Is this the best upgrade carb for the engine?  2- Will it fit with stock manifold? I ordered the Suzuki Samuri  conversion kit with carb...
    • Old thread, but for new readers, you need to buy a battery isolator, which is just two diodes mounter on a heat sink.
    • Thanks for the tips Aussie1. The choke cable appears to be working fine, although I have not measured cable movement to ensure it is within specs.  The machine is ten years old, but it has only 600 kms on it. I suppose I could check valve clearances, but I haven't largely because of the low mileage, and because it goes from running fine to flaming out. When you start it back up, it runs fine at idle as well at higher RPMs. However, once you let it idle again for a few seconds, it begins to pop a bit and then stalls.  If the valves required adjustment, I imagine the problem would be more consistent. I still suspect either a potential problem with the fuel delivery (I have a new pump on its way), or a faulty ignition coil. I guess I'll see if the problem is resolved once both parts are replaced. 
×