Jump to content

Textron Off Road UTV SxS Forum

Sign in to follow this  

This is is for all of you Textron Off Road UTV, SxS (Side by Side) owners. Discussion about Textron Off Road UTVs, including the Stampede, Prowler, Havoc, Wildcat, Wildcat X, Wildcat XX and other sub-models.

Sign in to follow this  

  • Latest Posts

    • Topic moved to Kawasaki UTV forum and added UTV info into topic title.😁
    • Travis, I'll give that a try in the morning and I'll take a picture too. I tried tapping on the pin with a punch and hammer and it didn't want to budge. I'll check to see if they've peened it over to keep it from coming out. Interesting that the parts diagrams don't list the pin separately, perhaps it comes with the replacement  cable.  I take it you've been inside one of these before. Kawasaki sure has a way of making it hard on anyone working on one of these.  The rear ignition-coil is another choice item to replace. You need to be a dwarf with a deformed arm. Thanks for your help, Gerry C
    • That cable  uses a simple snap pin that should pull right out with some pliers, some times where the pin goes through, they might have bent the bottom around to prevent it from coming loose. IF you can post a picture that would help some too.
    • I'd move the bug-eye headlights to the front and below the hood line as they are on the newer model Troopers.  Then put turn signal lamps were the headlights were.  Other than that, what you have looks real sharp.
    • I have a 2012 Kawasaki 4000 Mule and the hood release cable is frozen and will not move. I want to replace the cable and have removed the fenders, hood, cargo box to access the cable. I finally had to remove the plastic dash far enough away so I could get a wrench on the nut holding the cable release knob in place. That's a lot of fun. I cannot remove the pin holding the cable to the release bar mechanism. Is that a force fit pin or what. There are no keepers holding it in place. Any suggestions on how to get the cable out? I can see why the previous owner never fixed it as you have to remove the whole front to get to the cable. I've tried penetrating fluids to make the cable work with no success. Your help is appreciated. Gerry C.